help fast lights dont work - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-22-2005
01BlkEdge's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Deer Park, Texas
Posts: 145
help fast lights dont work

I just replaced my headlights and fogs with some of the Cool Blue lights from Sylvania, and put some red leds in my turn signals. Well I just realized that my gauges dont work, and my taillights dont work until I push the brakes any help on what is wrong. I just a ticket for defective equipment, thats how I realized they were out. My fogs dont work anymore either. I put the originals in them, and they wont work.
Reply With Quote
  #2  
Old 03-22-2005
yellerEDGEchick's Avatar
Member
 
Join Date: Jun 2004
Location: Texas
Posts: 1,690
hmm...maybe you didnt hook something back up right...check everything again and see maybe if its possible that you blew a fuse? or am i being dumb...

just double check and make sure you hooked everything back up correctly...
Reply With Quote
  #3  
Old 03-22-2005
FoMoCoFiddy's Avatar
Member
 
Join Date: May 2004
Location: Smackdownville Tx
Posts: 4,508
Maybe you blew a fuse there turbo.
Reply With Quote
  #4  
Old 03-22-2005
Zero's Avatar
Member
 
Join Date: Jun 2004
Location: Poteau, Oklahoma
Posts: 435
Yeah sounds like Master Leo would prob. be right here. Sounds most likely to be a fuse problem...
Reply With Quote
  #5  
Old 03-22-2005
01BlkEdge's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Deer Park, Texas
Posts: 145
I checked every fuse in the fuse panel and there all fine.
Reply With Quote
  #6  
Old 03-22-2005
Member
iTrader: (1)
 
Join Date: Jun 2004
Location: Belleville, Il
Posts: 972
under the hood maybe or maybe the switch might be broke too does ur head lights come on or is it just the stuff u said
Reply With Quote
  #7  
Old 03-22-2005
01BlkEdge's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Deer Park, Texas
Posts: 145
My headlights work fine, but my taillights wont come on, my interior lights dont work and my corner lights dont work. I've gone through every fuse atleast 3 times and I cant find one thats blown. Also this is really off of what I am asking, but does anybody know if I get this fixed and go to the court will they dismiss the ticket.
Reply With Quote
  #8  
Old 03-22-2005
Zero's Avatar
Member
 
Join Date: Jun 2004
Location: Poteau, Oklahoma
Posts: 435
Did you check the fuse box under the hood? I dont know what all they control for sure but thats a possibility...
Reply With Quote
  #9  
Old 03-23-2005
Member
 
Join Date: May 2004
Location: Fuquay Varina, NC
Posts: 3,048
make sure to check the fuse under the hood, then take those LEDs out!! some cheap LEDs can cause all sorts of strange problems when they are in, it cant hurt to switch them back to stock
Reply With Quote
  #10  
Old 03-23-2005
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,833
Check fuse 33 in the underhood fuse/relay box. It powers the dash lights and all of the external running lights except the headlights.
Reply With Quote
  #11  
Old 03-23-2005
loneFX4's Avatar
Member
 
Join Date: Jan 2005
Location: Summerville,SC
Posts: 955
dont LEDs require less power to operate then stock lights? this may cause a problem with completed circuits which have to be done for lights to work.
Reply With Quote
  #12  
Old 03-23-2005
Member
 
Join Date: Nov 2004
Location: Danville, VA
Posts: 2,664
the court can drop it if u can prove u fixed the problem since the ticket...thas if the judge wants to be cool with you
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
help - back up lights dont work OVERtheEDGE General Technical & Electrical 15 09-12-2009 02:54 PM
I want to fast, I want to fast! redrangeradrian 4.0L OHV & SOHC V6 Tech 50 04-16-2009 04:24 PM
dont like jap / korean cars, dont open this thread. Melt Snapshots 26 01-23-2009 09:06 AM
Found out why my OHC map lights dont work... jtslmn720 General Technical & Electrical 8 10-08-2007 08:10 PM
KC lights dont work Lord Of War General Technical & Electrical 15 09-21-2007 02:05 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:10 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.