Horn Troubleshooting Help - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-14-2011
Member
Thread Starter
 
Join Date: Jun 2011
Location: Richlands NC
Posts: 15
Horn Troubleshooting Help

I have a 98 Ranger that failed inspection as the horn recently went out. I never use the horn so god only knows how long it has been out. I uninstalled the dual horn from the frame, cleaned all the contacts on horn and frame (as frame is the ground). Reinstalled still no horn. The horn chimes when keyless entry is used to lock the vehicle. I took some jumper cables and supplied power to the horn directly from the battery and it worked just fine.
I checked the HORN Fuse, looks good.
As for the relay I swapped it out with the fuel pump relay and washer pump relay, no change, horn still did not work.

I disconnected battery, removed air bag from sterring colum, reconnected battery, pressed the plates directly on sterring column to make sure contact was being made, still no HORN.

My AIR bag light is not on, my cruise control still works, turn signals work.

I am assuming there is an electrical problem between the pressure plates on the steering column and the fuse/relay box.

Any help would greatly be appreciated, thanks.

ALSO, would it just be easier to install a dash button for the horn to pass inspection? If so can anyone give me pointers on that. The horn works, just not sure how to install a button on the dash that will make the horn work, the whole wiring issue is puzzling to me.

Thanks
RJ HARRY
USMC
Camp Lejeune NC
98 Ranger XLT
03 Expedtion XLT
01 F150 XLT
Reply With Quote
  #2  
Old 06-14-2011
buckgnarly's Avatar
Member
iTrader: (11)
 
Join Date: Jan 2005
Location: West Topsham, VT
Posts: 1,709
Are you getting 12v at the switch on the wheel? Do you hear the relay click when you hit the horn? Sounds like I would start at teh switch on the wheel.
Reply With Quote
  #3  
Old 07-17-2011
Member
Thread Starter
 
Join Date: Jun 2011
Location: Richlands NC
Posts: 15
Was not getting any volts at the horn in the sterring wheel, looks like I have a bad clock spring as my cruise control wasnt working either. I found power up to where the clock spring wring harness connected. I ended up putting a horn button on the dash to the left of the steering wheel as a quick fix to pass inspection. Thanks
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Troubleshooting No Horn cantdrive55 General Technical & Electrical 10 06-11-2014 11:15 AM
Help with troubleshooting starter problem 99ranger ranger99ct General Technical & Electrical 0 07-14-2011 07:29 AM
Help Troubleshooting Sub setup Woods-Rider Audio & Video Tech 15 05-06-2010 12:44 AM
Need Help Troubleshooting.. God,Country,FORD 4.0L OHV & SOHC V6 Tech 4 08-17-2009 04:09 PM
TroubleShooting Help! Trigger01 Audio & Video Tech 7 12-30-2007 02:35 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:11 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.