New Battery. Used to start, no longer will - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-04-2015
Member
Thread Starter
 
Join Date: Nov 2015
Location: Billings, MT
Posts: 2
New Battery. Used to start, no longer will

Hello! my 1984 ford ranger 2.3l truck just stopped working this morning. I purchased this the other week and yesterday I replaced the battery, sparkplugs, sparkplug wires, and fuel filter last night.

everything seemed ok, but after driving today, I tried to start it and it made a weird crunching noise. Maybe the starter?

After getting push started, i got it home, but noticed that when i braked, the radio would fade out.

when i parked, I turned the lights on, the truck tried to stall, so I gave it some gas and it back fired. After i turned it off, the truck would no longer turn over, and nothing electrical would turn on. No radio or lights. Maybe a ground or bad connection somewhere could be the cause? Im at a loss at this time. not sure what to do.

Thanks for your help.

Ben
Reply With Quote
  #2  
Old 11-05-2015
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,595
Why did you replace the battery?

You need to get a volt meter.
A new battery will show 12.8volts when fully charged
5-6 year old battery will show 12.2volts fully charged, and time to shop for new battery
Under that you are looking at a drained battery or a bad battery.

It reads like battery is not being recharged and that battery is also running all the electrics on the vehicle when engine is on, and it shouldn't be, battery is only used to start the engine, that is it's only purpose.

The alternator on the engine is used to power all the electrics on the vehicle when engine is running, it also recharges the battery after it is drained from starting engine.

1984 will also have a separate Voltage Regulator hooked to the alternator to keep vehicle voltage between 13.5 to 14.9volts, this prevents under voltage and battery drain and over voltage which burns out devices and fuses.

After recharging the battery the engine should start
Once it is running check voltage at battery, should be 13.5 to 14.5volts
If it is 12.x volts then alternator or regulator is not on or it's voltage is not getting to the battery.
Turn off engine.

On the back(or side) of the alternator will be a larger wire, usually black with orange stripe
That wire is connected directly to the battery at the starter relay(solenoid) post on the fender.
So that wire should have 12volts 24/7, all the time, test that it has 12volts
If not you will need to trace that wire back to starter relay, near the relay it will have a Fusible link, that can "blow"(separate) and would need to be replaced.

The voltage regulator should be on the fender, it should have 4 wires hooked up, remove connector and make sure all the wires are good in that connector, not frayed or corroded.
There should be a Light Green/red stripe wire on that connector, that wire is the ON/OFF switch for the voltage regulator.
This wire should have 12volts when key is on and no volts when key is off.
If no volts with key on then ignition switch could be your problem or the wire itself.
Reply With Quote
  #3  
Old 11-09-2015
Member
Thread Starter
 
Join Date: Nov 2015
Location: Billings, MT
Posts: 2
Thank you for your help. I was able to locate the issue with your advice. I just purchased the truck and the battery that was in there was very old. With a cold winter coming up, I had decided to replace it to be safe.

After changing the alternator and the voltage regulator, everything for the last couple of days seem to be working very well!
Reply With Quote
  #4  
Old 11-09-2015
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,595
Good work

Thanks for the update
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Trys to start as soon as i hook the battery up? RANGER_620 General Technical & Electrical 11 12-19-2011 10:06 PM
2004 Ranger Won't Start, No lights, Battery Good Baxter General Technical & Electrical 7 08-20-2011 06:36 AM
eBay / Craigslist Find: Used Alcoas, Brand new 15inch deer toes, Used MT Polished Classic IIs for CHEAP -OHIO Masteratarms93 eBay & Craigslist Finds 7 05-09-2011 10:07 PM
1996 Battery light coming on, yet battery and alternator work' SariahLeah SOHC - 2.3L & 2.5L Lima Engines 2 06-04-2010 04:16 PM
running battery down, battery discharge from playing an amp'd system onebluemcm Audio & Video Tech 12 04-13-2007 04:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:01 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.