Power loss/surges?? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-18-2010
Member
Thread Starter
 
Join Date: Jan 2009
Location: Fresno, CA
Posts: 7
Power loss/surges??

Hey folks, got a manual 1998 Ranger 3.0 4x4. Been having problems accelerating, especially from a dead stop. It would speed up fine, but all of a sudden slow down then pick back up again.. At first it would just be the first couple gears, but after riding on it for a month now, it seems to happen almost every time I accelerate no matter how fast I'm going or what gear I'm in. And just recently I had gotten a check engine light.

I'm not gunning it, and I can usually ease into the clutch slow enough so it wouldn't happen, but is gradually getting worse. Any suggestions? Any would be helpful, thank you!
Reply With Quote
  #2  
Old 09-18-2010
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
sounds to me like a misfire under load...what is the code that its throwing...ever due a tune up on it
Reply With Quote
  #3  
Old 09-19-2010
Member
Thread Starter
 
Join Date: Jan 2009
Location: Fresno, CA
Posts: 7
Tune up was supposedly done before I got the truck (guess it won't hurt to try), but the code that I got done yesterday read PO306...but also had Catalyst Monitor, EVAP Monitor, O2 Sensor Monitor and O2 Sensor Heater Monitor - all of which hadn't completed self-testing.

Last edited by 7dsenvy; 09-19-2010 at 11:06 AM.
Reply With Quote
  #4  
Old 09-19-2010
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
id check the converter it might be clogged...my buddies bronco did the same thing when his cat was clogged
Reply With Quote
  #5  
Old 09-19-2010
Member
Thread Starter
 
Join Date: Jan 2009
Location: Fresno, CA
Posts: 7
I've had people tell me the same thing, think I'll give it a go. Thanks man!
Reply With Quote
  #6  
Old 09-19-2010
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
no problem
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
RPM Surges jpiper 2.9L & 3.0L V6 Tech 0 10-12-2013 04:23 PM
1998 Ranger surges and drops under full throttle Guybak General Ford Ranger Discussion 1 10-12-2011 10:39 PM
2.3L surges with A/C on fnjrrd DOHC - 2.3L Duratec / Mazda L Engines 2 09-12-2010 04:19 PM
Loss of Power, Sounds like Vacuum Leak herm59 4.0L OHV & SOHC V6 Tech 4 12-09-2008 02:48 PM
98 Ranger (2.5 I4) idles, surges when given throttle Marlowe SOHC - 2.3L & 2.5L Lima Engines 6 09-21-2008 01:26 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:43 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.