Trailer running lights not working - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-02-2013
computerflake's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Nashville, TN
Posts: 146
Trailer running lights not working

I made a mess this weekend and I'm hoping you guys can help me out. I put new lights on my camper and accidentally smashed a wire against the trailer frame and it grounded it out. It blew the left and right blinker fuses so I replaced them and it fixed it. Before I made the mess, the running lights worked but now they don't. I checked all of the 7.5 amp fuses and none of them are blown so I can't figure out why the running lights don't work. I used my ohm meter and it doesn't show any power going to the wire for the lights but does for the blinkers. Any ideas? I would appreciate any/all help!
Reply With Quote
  #2  
Old 06-02-2013
computerflake's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Nashville, TN
Posts: 146
Well I may have answered my own question. It looks like there is a separate fuse in the power distribution box under the hood and fuse location 5 might be what I need. Not sure why they put the left and right turn signals in the interior fuse box and then stuck that one under the hood but that sounds like the one I'm looking for.
Reply With Quote
  #3  
Old 06-06-2013
mrmrrck's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2008
Location: Dover, TN
Posts: 115
Did that fix your lights?
Reply With Quote
  #4  
Old 06-06-2013
computerflake's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Nashville, TN
Posts: 146
Like a boss! :)

Just weird they put the 7.5amp fuses for the left and right blinkers in the interior fuse box and the running/brake lights are in the 15amp under the hood in the power distribution box.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Brake lights not working. It's not the brake switch. ColinGooseHall General Technical & Electrical 3 05-01-2015 08:35 PM
Brake and Signal Lights Not Working After Hooking Up Trailer. derek89 General Technical & Electrical 2 04-18-2013 08:49 PM
Ranger brake lights stopped working when trailer was hooked up, still don't work tomz General Technical & Electrical 10 10-08-2010 05:46 PM
HVAC lights, headlight switch light, 4wd lights not working.... Jwad00 General Technical & Electrical 1 09-05-2009 04:45 PM
Left blinker and brake light not working on trailer connector!? ReelMagic15 General Technical & Electrical 6 07-09-2009 12:27 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:21 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.