wipers, speedo, and odometer dont work - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 09-05-2009
littlered's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Lewistown, Mo
Posts: 1,542
Thanks for the link it was a big help!
Reply With Quote
  #27  
Old 09-06-2009
littlered's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Lewistown, Mo
Posts: 1,542
well today my dad took the cluster apart while i was working on the tractor. we found the part on it that shorted and i have pics but my computer isnt recognising my picture card so you will have to wait. but it was like a black round thing that stuck out beside the odomter. my dad who is an electrican said we can get one at radio shack and soider it on. is this a good idea or should i just get a new cluster?
Reply With Quote
  #28  
Old 09-07-2009
joatmon's Avatar
Member
 
Join Date: Jul 2007
Location: SMC MD
Posts: 54
IF your dad can fix it for the price of a component from Radio shack, then do that first. Might just blow again bcause of some other problem, but it won't set you back a lot of cash to try that first.
Reply With Quote
  #29  
Old 09-07-2009
Rangerguy's Avatar
Member
 
Join Date: Feb 2008
Location: California
Posts: 1,120
Glad you're making some progress. Good luck!
Reply With Quote
  #30  
Old 09-08-2009
littlered's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Lewistown, Mo
Posts: 1,542
well i got a cluster out of a wrecked ranger that my friend had but i am going to try and fix mine and see if it works if not i will buy one and give him his back. Anyway i got the pics so here yuo go.

the round black thing that is hanging down is what burnt and it discolored the gears on the odometer.


this is how i drove around for one night and part of the next day



Thanks for all of the help!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
94 ranger turn signals won't work! v6 4x2 all other lights and wipers work not fuse? kappesdeb General Technical & Electrical 0 07-17-2014 12:45 PM
Windshield wipers dont always work thewoerd General Technical & Electrical 1 04-04-2014 06:34 AM
New gears and 35s... Speedo and Odometer way off!!!! MugenCRX04 Drivetrain Tech 31 09-15-2009 11:40 PM
Speedo/Odometer Recalibration jamesxEDGE General Technical & Electrical 3 12-05-2007 07:36 PM
Odometer and Speedo stuck- help asap...!? Kelt General Ford Ranger Discussion 5 12-06-2006 04:06 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:41 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.