Mustang Dome Light Help - Ranger-Forums - The Ultimate Ford Ranger Resource


Interior Semi-Tech General discussion of interior for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-15-2014
redranger04g's Avatar
Member

Thread Starter
iTrader: (2)
 
Join Date: Apr 2007
Location: Placentia, CA
Posts: 928
Mustang Dome Light Help

I have a 2004 Ranger and I installed the mustang dome light with buggman's LEDs (they are awesome). However, I am having some troubles.

The light will work perfectly, then all of a sudden none of them will work. Then sometimes only the dome light will work and not the map lights. I can usually get the dome light to work by opening and closing the door a couple times. Sometimes when I turn on my map lights they are barely visible and flickering.

Anyone have any ideas? The map lights are wired on for constant power (still after the 10 minute relay). While the dome light is wired to the standard dome light. It seems odd that both will sometimes stop working, and sometimes only the dome will work. They are separate power sources aren't they?

Thanks in advance for the help.
Reply With Quote
  #2  
Old 01-15-2014
99offroadrngr's Avatar
TOYOTA
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
sounds like a wiring issue to me. check your connections and grounds
Reply With Quote
  #3  
Old 01-15-2014
redranger04g's Avatar
Member

Thread Starter
iTrader: (2)
 
Join Date: Apr 2007
Location: Placentia, CA
Posts: 928
It sounds like it has to be a ground if both lights with separate power sources are off correct?

It is very difficult to check connections since the screws used to put in the dome light are what makes connection. And it only does this when completely installed.

Do you think running a better ground somewhere else in the truck would help?
Reply With Quote
  #4  
Old 01-21-2014
redranger04g's Avatar
Member

Thread Starter
iTrader: (2)
 
Join Date: Apr 2007
Location: Placentia, CA
Posts: 928
So after I close my doors from opening them, the light will not work for about 10 minutes. Then it works again. Anybody know what would cause this? It's like the 10 minute 'timer' is working backwards
Reply With Quote
  #5  
Old 01-24-2014
redranger04g's Avatar
Member

Thread Starter
iTrader: (2)
 
Join Date: Apr 2007
Location: Placentia, CA
Posts: 928
Solved the problem, I replaced the fuse and it works normally. Weird though, fuse wasnt blown and horn still worked (same fuse).
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How-To: 3rd Brake light Cargo Lights Using Mustang Dome Light rideabikenick Interior, Exterior, & Electrical 4 10-07-2009 08:29 AM
Help with mustang dome light on 2007 lvl II Yukon Ranger General Technical & Electrical 10 08-22-2009 12:49 PM
Gray/black OHC, Taurus Dome Light, Stock 3 bulb dome light- GA MugenCRX04 Interior, Exterior, Electrical, & Misc. 10 08-03-2009 08:11 PM
Explorer/Mustang Dome light vs. Stock 3 bulb Dome slowrey Interior Semi-Tech 15 05-23-2009 09:05 PM
Mustang dome light? Buttercup General Ford Ranger Discussion 8 01-04-2005 12:51 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:49 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.