newbie with electrical problems - Ranger-Forums - The Ultimate Ford Ranger Resource


Member Introductions New to Ranger-Forums.com? Please take a moment and introduce yourself.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-24-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: albuquerque
Posts: 2
newbie with electrical problems

i recently bought my ranger and it has 99500miles on it and quite a few problems, the 4x4 doesnt engage, the back window is broken out, the turn signals dont work but i know its just the 552 flasher. the exhaust rattle, and the dome light doesnt work, the bodys pretty decent but has quite a few dings and dents in it, it has a half assed 4 inch body lift on it with a broken leaf spring in the back, it does have bigger and wider tires, although the two front tires are pretty much done. The guy i bought it off of beat the **** out of it and left it in his garage for ten years. Ive already done some minor things to bring the engine back to life. all in all i have my work cut out for me. today i tried to fix my turn signals. i figured out it was the relay since i tried the a new switch aswell as a new fuse, so when i try to start my truck to go to autozone to get a 552 my truck wont start, so i try and jump it and all it does is spark( i had all of the jumper cables hooked up correctly). So i get my buddy to give me a ride to autozone and get a new battery and 552, i came back and threw the relay in and then went to connect the battery, i honestly think i ****ed up by attaching the the negative(black) first and then when i put the positive(red) on it arched and after that i tried to start it; no dice. i checked the fuses in the engine bay and both alt. power one and two are fried and probably my altenator, at this point i couldnt be more bummed so i am here reaching out for your guys help.
Reply With Quote
  #2  
Old 08-24-2010
Machine090767's Avatar
RF Veteran
 
Join Date: May 2006
Location: Minnesota
Posts: 6,410
welcome to R-F, Trav!
Reply With Quote
  #3  
Old 08-24-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
And I thought I had issues , WOW !

First thing to do Trav is to get a Haynes manual .

Welcome and good luck.
Reply With Quote
  #4  
Old 08-24-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: albuquerque
Posts: 2
alright so it turns out im slightly retarted. i had the battery in backwards so i connected the negative to positive. yeah i know , it was stupid. anyways i got the turn signals working and it runs so much better with the new battery. so now all i have to do is fix the window, 4x4 and grab 2 new tires and ill be rolling much happier. thank you everyone for the advice.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Crazy electrical problems!!!help!!! RangerDanger21 General Technical & Electrical 6 02-21-2009 02:34 PM
HELP! Electrical problems! Step Over the Edge General Technical & Electrical 3 02-01-2009 05:31 PM
Few electrical problems Bobburt444 General Technical & Electrical 2 01-19-2009 12:12 PM
Electrical Problems, need help! Grizzly General Technical & Electrical 2 08-28-2008 04:46 PM
Electrical problems.. Help Bob! r0ng5 General Technical & Electrical 6 02-05-2007 10:35 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:18 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.