95 Ranger- Hard start and bogging - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-04-2011
YYZ YYZ is offline
Member
Thread Starter
 
Join Date: Jan 2011
Location: tempe
Posts: 10
95 Ranger- Hard start and bogging

Newbie here. Given this 95 automatic trans, 2.3 with 130K. Does run but hard starts. When running bogs out when stepping on it or stalls.
So far replaced new plugs and wires (OEM), fuel filter and cleaned the IAC and MAF. Pulled the thottle body and intake and found broken vaccum hose to thottle body and broken vaccum hose to EGR. My Question!!

What else should I look at or replace while I have this tore apart?
Also cant get the EGR off the pipe from exhaust. Thanks for anyone's time. Just want to make this safe for my son to drive.
Reply With Quote
  #2  
Old 01-07-2011
Member
 
Join Date: Oct 2010
Location: Jacksonville fl
Posts: 12
I'm having the same problem with my 97 ranger. When its cold it likes to stall when at a stop. Did changing the plugs do anything?
Reply With Quote
  #3  
Old 01-07-2011
YYZ YYZ is offline
Member
Thread Starter
 
Join Date: Jan 2011
Location: tempe
Posts: 10
When it starts now it does sound and run better but it still dies. EGR, PCV, and vaccum line repairs this weekend. Not sure about the fuel pressure regulator or O2 sensors. Need it to run long enough to pull codes.
Reply With Quote
  #4  
Old 01-07-2011
Hows My Driving's Avatar
Member
 
Join Date: Dec 2010
Location: Georgetown, OH
Posts: 17
Could also be dirty injectors?
Reply With Quote
  #5  
Old 01-09-2011
YYZ YYZ is offline
Member
Thread Starter
 
Join Date: Jan 2011
Location: tempe
Posts: 10
Starts better but still not the way it should be. If I easy into the gas it responeds fine. But if I press into it a litttle hard it all most stalls and backfires but then recovers and RPM increases. Dont know when to go from here. Injectors, fuel regulator, pump ???? Stumped at this point.
Reply With Quote
  #6  
Old 01-09-2011
jtfoxman's Avatar
Member
 
Join Date: Jun 2005
Location: The Poconos
Posts: 891
Wirelessly posted

Check ur fuel pressure first
Reply With Quote
  #7  
Old 02-12-2011
YYZ YYZ is offline
Member
Thread Starter
 
Join Date: Jan 2011
Location: tempe
Posts: 10
Finally got some time to lookat this.
Tested pressure at the rail. It never gets above 20 psi even when running!
Questions.
Should it hold pressure when not running?
What should the pressure be when running as it will start, but when stepping on the gas it will die unless Iease into the throttle.
Sounds like fuel pump but is there anything else to consider?
Reply With Quote
  #8  
Old 03-02-2011
YYZ YYZ is offline
Member
Thread Starter
 
Join Date: Jan 2011
Location: tempe
Posts: 10
Fuel pump replaced. Started first turn.
36 psi at the rail with the engine off but key turned on. 40 with it running. Now have CEL on but its running well and acceleration has return.

The truck failed AZ emissions so on to fixing that. It passed tail pipe values and gas cap check but failed pressure test. Any ideas?
Reply With Quote
  #9  
Old 03-04-2011
Member
 
Join Date: Mar 2007
Location: Ringgold,GA
Posts: 8
i have a 98 2.5 mine has been bogging for awhile now. i pulled all the codes and a P1409 came up which is the EVR.if it starts back like mine did about 6 months after replacing the pump you may want to check into that.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2.3L bogging down after start 03WhiteRanger DOHC - 2.3L Duratec / Mazda L Engines 3 06-19-2012 07:19 PM
Ranger hard start issue HELP COLD START 1994splash 2.9L & 3.0L V6 Tech 1 06-08-2011 05:27 PM
1989 ranger 4 cyl bogging no power ffemtjaydoc SOHC - 2.3L & 2.5L Lima Engines 5 02-11-2011 10:04 AM
Sluggish, bogging, shaking 1998 Ranger RangerXtreme Drivetrain Tech 3 08-14-2010 04:40 AM
1992 Ranger 4.0 Bogging Down lepp1892 4.0L OHV & SOHC V6 Tech 1 11-02-2009 08:52 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:36 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.