97nranger no start - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 6 Days Ago
Member
Thread Starter
 
Join Date: Aug 2017
Location: tacoma, wa
Posts: 5
97nranger no start

Yes it took me a while to figure out the forum it has popups and my computer drags. Anyways, I have a 97 ranger 4 cylinders with 8 plugsthat will not start. There is no power to the inertia switch and the switch isgood. The pump will run hotwired. The bed is off. I replaced the ignition and 2 relays still norun. I will look better for bad grounds and lose wires. Where would I get afactory wiring diagram. it looks like this one is going to post dark also do not know why!!!
Thanks guys Steve
Reply With Quote
  #2  
Old 6 Days Ago
Member
Thread Starter
 
Join Date: Aug 2017
Location: tacoma, wa
Posts: 5
Yes it took me a while to figure out the forum it has pop ups and my computer drags. Anyways, I have a 97 ranger 4 cylinders with 8 plugs that will not start. There is no power to the inertia switch and the switch is good. The pump will run hotwired. The bed is off. I replaced the ignition and 2 relays still no run. I will look better for bad grounds and lose wires. Where would I get a factory wiring diagram.
Thanks guys Steve







Yes it took me a while to figure out the forum it has popups and my computer drags. Anyways, I have a 97 ranger 4 cylinders with 8 plugsthat will not start. There is no power to the inertia switch and the switch isgood. The pump will run hotwired. The bed is off. I replaced the ignition and 2 relays still norun. I will look better for bad grounds and lose wires. Where would I get afactory wiring diagram.


Thanks guys Steve

Reply With Quote
  #3  
Old 6 Days Ago
Member
Thread Starter
 
Join Date: Aug 2017
Location: tacoma, wa
Posts: 5
Yes it took me a while to figure out the forum it has popups and my computer drags. Anyways, I have a 97 ranger 4 cylinders with 8 plugsthat will not start. There is no power to the inertia switch and the switch isgood. The pump will run hotwired. The bed is off. I replaced the ignition and 2 relays still norun. I will look better for bad grounds and lose wires. Where would I get afactory wiring diagram.
Thanks guys Steve
Reply With Quote
  #4  
Old 6 Days Ago
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 6,931
Welcome to the forum

Don't post in BLACK it is hard to read

So the engine turns over with starter motor but will not start?

Spray gasoline or Quick Start(ether) in to the intake and then try to start engine.
50/50 test, that will tell you if spark or fuel is the issue
If it starts and dies then a fuel delivery issue
If still no start then spark is the issue


The fuel pump only runs for 2 seconds when key is turn on, that is normal, it won't run full time until engine starts, RPMs above 400

Fuel pump power comes from Maxi-Fuse #12 in engine fuse box, 20amp
It is sent to inertia switch when Fuel Pump relay is closed by the computer, 2 seconds only
You can turn key on and off as much as you like and you will get that 2 seconds of power each time

Inertia switch in the cab just passes the power to the fuel pump unless it has been "tripped", opened, red reset button on the top will be UP, and dash light Fuel Reset will be lit.

PCM relay(engine fuse box) does power the coil in the fuel pump relay, but it also powers PCM(computer), fuel injectors and some sensors, if CEL(check engine light) comes on with the key then PCM relay and its fuse are OK

And just a heads up on the 4cyl Lima engines(2001 and earlier Rangers), only the exhaust side coil and spark plugs work when starter motor is active, i.e. during start up
Intake side starts when RPMs are above 400

Here are the wiring diagrams
Attached Files
File Type: pdf 1997 2.3l-1.pdf (55.5 KB, 8 views)
File Type: pdf 1997 2.3l-2.pdf (51.7 KB, 5 views)
File Type: pdf 1997 2.3l-3.pdf (40.1 KB, 4 views)
File Type: pdf 1997 2.3l-4.pdf (58.3 KB, 6 views)

Last edited by RonD; 6 Days Ago at 05:27 PM.
Reply With Quote
  #5  
Old 2 Days Ago
Member
Thread Starter
 
Join Date: Aug 2017
Location: tacoma, wa
Posts: 5
Yes the engine temporarily starts with starter fluid into the plenum. Thank you for the wiring diagrams. I will check out what you suggested.
steve
Reply With Quote
  #6  
Old 1 Day Ago
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 6,931
Then you for sure have fuel delivery problem

I did read of one 2.3l starting issue where the TPS(throttle position sensor) was shorted out, it sent 5volts to the computer all the time, this tells computer to SHUT OFF fuel injectors during startup.
It is called Clear Flooded Engine routine
Unplug the TPS and try to start engine

Very very rare occurrence, only read about it one time, but easy to test
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
87 2.3L no start start pness.mtl 2.3L & 2.5L I4 Tech 1 1 Week Ago 03:50 AM
only start on easy start kyde General Technical & Electrical 2 05-25-2014 05:17 AM
Incorrect jump start. Truck won't start now. Pilot General Technical & Electrical 3 10-27-2013 07:07 AM
Won't start, dome light dies when trying to start. Jerkstore General Technical & Electrical 4 10-02-2011 09:53 AM
Ranger hard start issue HELP COLD START 1994splash 2.9L & 3.0L V6 Tech 1 06-08-2011 04:27 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:05 AM.