found the problem - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-27-2007
anthony84_2004's Avatar
Member
Thread Starter
 
Join Date: Apr 2006
Location: Jesup, Georgia
Posts: 760
broke the piston.

got the head off of the 93 today. It wasn't pretty, looks like it's time for a v8.Damn.

oh well on with the pics

Name:  Picture026.jpg
Views: 2
Size:  163.1 KB

nice piston

Name:  Picture025.jpg
Views: 1
Size:  93.8 KB

Name:  Picture024.jpg
Views: 1
Size:  112.8 KB

I may be parting out some of the parts: heads are still good, tranny, header, intake manifold, etc.

Last edited by anthony84_2004; 02-27-2007 at 04:54 PM.
Reply With Quote
  #2  
Old 02-27-2007
Trigger01's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Oct 2005
Location: Knoxville, TN
Posts: 18,788
I like that shade of green. A V8 will be very nice in there.
Reply With Quote
  #3  
Old 02-27-2007
anthony84_2004's Avatar
Member
Thread Starter
 
Join Date: Apr 2006
Location: Jesup, Georgia
Posts: 760
Quote:
Originally Posted by Trigger01
I like that shade of green. A V8 will be very nice in there.
I;m thinkin about a 350, since I got one over at my freinds shop, I would rather have a 302...but for the price I can get the 350, I might get it.
Reply With Quote
  #4  
Old 02-27-2007
RF Veteran
 
Join Date: May 2005
Location: College Station, TX
Posts: 5,782
What is that green stuff?
Reply With Quote
  #5  
Old 02-27-2007
SouthernMudSlinger's Avatar
Member
 
Join Date: Aug 2006
Location: Demorest,Ga
Posts: 1,724
Quote:
Originally Posted by Gearhead61
What is that green stuff?
Anti-freeze..............
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
CB: finally found problem Ranger928 General Technical & Electrical 5 07-18-2009 06:53 PM
Found the tranny problem!!!!!!! 03bamaGT Drivetrain Tech 6 03-05-2007 11:51 PM
I think I found the problem!!! NicksterSVT 4.0L OHV & SOHC V6 Tech 25 02-13-2007 02:13 PM
Took apart the dash.. ..and found a problem.. FX2.3 General Technical & Electrical 6 01-21-2007 06:04 PM
Well, I found out the problem. Wertzy 2.9L & 3.0L V6 Tech 12 01-05-2006 04:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:54 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.