PLEASE HELP! - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-26-2016
Member
Thread Starter
 
Join Date: Feb 2016
Location: morganville
Posts: 3
PLEASE HELP!

I have a 1985 ford ranger 2.3l 5sp Manuel 4x4. I was driving the other day and it just shut off and it wouldn't start back up. It cranks over but doesn't start. I'm not getting any spark. I replaced ignition coil, ICM, wires, cap and rotor and there is little spark and it's not strong or constant. There is no crank sensor for this truck either. Please help!!
Reply With Quote
  #2  
Old 02-26-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,613
Crank sensor is the distributor.
When distributors were removed crank sensors were added/needed.

Does the rotor turn when cranking the engine?
So timing belt is not broken.

Do you have a carb or fuel injection?
Have you tried adding fuel manually if fuel injected.

For an engine to just die while driving there are only a few things to look at.
Broken timing belt is first.
No fuel is second, add fuel manually to intake and see if engine starts then dies, so no fuel from fuel system.

Spark this 3rd, check for full 12volts at Coil +
Reply With Quote
  #3  
Old 02-26-2016
Member
Thread Starter
 
Join Date: Feb 2016
Location: morganville
Posts: 3
The rotor is not spinning when I crank the motor over
Reply With Quote
  #4  
Old 02-26-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,613
Then timing belt is broken.
If distributor is not turning then ICM doesn't know when to make a spark.

It didn't damage the engine, Lima 2.3l is a non-interference engine.
Reply With Quote
  #5  
Old 02-26-2016
Member
Thread Starter
 
Join Date: Feb 2016
Location: morganville
Posts: 3
Thank you I appreciate your help
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
please help please devinemississippian SOHC - 2.3L & 2.5L Lima Engines 5 02-12-2016 10:02 PM
PLEASE PLEASE PLEASE.... annguyen1981 General Ford Ranger Discussion 13 12-05-2013 03:35 PM
please tell me where my PCV is, Please (did search) uplandhunter General Technical & Electrical 16 02-07-2011 09:34 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:49 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.