Need Help 03 4.0L SOHC PO171 to lean - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-06-2010
Member
Thread Starter
 
Join Date: Oct 2010
Location: New Hampshire
Posts: 36
Need Help 03 4.0L SOHC PO171 to lean

Hello i have a 03 ranger 4.0L SOHC and i put in a K&N intake in my truck and my check engine light keeps coming on and i get the code PO171 to lean is there anyway to fix this without taking out my intake if so please help.
Reply With Quote
  #2  
Old 10-06-2010
Ford04Ranger4.0's Avatar
Member
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Idk what that code is but have you cleaned your throttle body and MAF yet?
Reply With Quote
  #3  
Old 10-06-2010
Member
Thread Starter
 
Join Date: Oct 2010
Location: New Hampshire
Posts: 36
No i have not do you think that could be the problem cause even when i just have my truck started in the driveway the light will go on and i would get that code saying that its running to lean? i think is PO171 im not sure if that's the right name idk
Reply With Quote
  #4  
Old 10-06-2010
Ford04Ranger4.0's Avatar
Member
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
I had a problem with my K&N filter gummin gup my maf and tb but I never got a cel. It was causing voltage spikes making my truck "buck" under a load. It doesnt hurt to clean it.
Reply With Quote
  #5  
Old 10-06-2010
Member
Thread Starter
 
Join Date: Oct 2010
Location: New Hampshire
Posts: 36
ok i will try that is there a special tool to take of the MAF bolts??? if so where can i find it
Reply With Quote
  #6  
Old 10-07-2010
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
its just a tamper proof torx bit...did you check that very problematic vac hose elbow thats under the throttle body?
Reply With Quote
  #7  
Old 10-07-2010
spartan72's Avatar
Member
 
Join Date: Nov 2007
Location: Oakwood, GA
Posts: 262
I had the same problem a few years back. Excpet both banks were running lean. Check the vac hose, pcv valve, and pcv hose. Sometimes they just pop loose.
Reply With Quote
  #8  
Old 10-07-2010
Ford04Ranger4.0's Avatar
Member
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Quote:
Originally Posted by Bballplayer545 View Post
ok i will try that is there a special tool to take of the MAF bolts??? if so where can i find it
You can clean the maf right in the tube, just make sure when you go to start it up its dry and you reset the computer.
Reply With Quote
  #9  
Old 10-07-2010
Member
Thread Starter
 
Join Date: Oct 2010
Location: New Hampshire
Posts: 36
I am going to check everything tomorrow is there a specific way to clean the MAF what do I use to clean it?
Reply With Quote
  #10  
Old 10-08-2010
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
go to an auto parts store and get MAF cleaner and read the directions
Reply With Quote
  #11  
Old 10-08-2010
Member
Thread Starter
 
Join Date: Oct 2010
Location: New Hampshire
Posts: 36
I found out the problem it was the vac hose elbow under the throttle body it was cracked in two spots. I'm going to the auto parts store in the morning to pick up a new one thanks guys you really help me out I appreciated it thanks

Last edited by Bballplayer545; 10-08-2010 at 10:28 PM. Reason: Had to add in a word
Reply With Quote
  #12  
Old 10-09-2010
Ford04Ranger4.0's Avatar
Member
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Quote:
Originally Posted by Bballplayer545 View Post
I found out the problem it was the vac hose elbow under the throttle body it was cracked in two spots. I'm going to the auto parts store in the morning to pick up a new one thanks guys you really help me out I appreciated it thanks
No problem but really I would clean the MAF and TB still, doesnt hurt.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fix for Check Engine light codes: p0401, po171 and po174 TheBearJeweler General Ford Ranger Discussion 66 02-05-2013 09:54 AM
Fault codes PO171 PO174 dochawken 2.9L & 3.0L V6 Tech 2 09-16-2010 05:09 PM
po171 and 174 codes ranger02 4.0L OHV & SOHC V6 Tech 14 05-08-2009 07:13 AM
po171 and po174 strakill 4.0L OHV & SOHC V6 Tech 6 03-22-2009 12:42 AM
lean bank 1 / lean bank 2 acxlt01ranger4x4 4.0L OHV & SOHC V6 Tech 4 06-24-2006 07:52 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:21 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.