Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Automatic's Downshift

  #1  
Old 03-10-2006
Member
Thread Starter
Join Date: Feb 2006
Location: Hawaii
Posts: 12
Automatic's Downshift

Sometimes when im cruzing at around 35-40mph, and gas it 100%, the trans doesnt shift down even if its rpm is too low to make power (got no tach but judging by sound), it has a low rumble which sounds mean but i would like it to shift like when im on the freeway and gas it. Anyone know how to fix this or do something to make it shift. Oh BTW, i tried putting the shifter in 2nd and it still dont shift.
 
  #2  
Old 03-10-2006
weaselbob74's Avatar
Member
Join Date: Feb 2006
Location: Normal, IL
Posts: 64
Mine does that too, and I have a tach. I just think thats how it is...or mine is messed up too
 
  #3  
Old 03-10-2006
3LiterBeater's Avatar
Member
Join Date: Jun 2004
Location: OC, CA
Posts: 879
If you dropped it manual to 2nd, and it still didn't go, your just going too fast...
 
  #4  
Old 03-10-2006
V8 Level II's Avatar
RF Veteran
iTrader: (4)
Join Date: Nov 2004
Location: Michigan
Posts: 7,910
If it doesn't downshift going from cruise to WOT at 35~40, something is definitely wrong.

Does the speedometer seem to work proprerly or is it erratic?

Do you see a Check Engine light or a flashing "O/D OFF" light or "ABS" light in the instrument cluster?
 
  #5  
Old 03-10-2006
black-n-blue's Avatar
Member
Join Date: May 2005
Location: Garner, NC
Posts: 810
mine was sluggish downshifting until i got a new fuel filter.. i know it sounds sketchy but it did the trick.
 
  #6  
Old 03-10-2006
jtslmn720's Avatar
RF Veteran
iTrader: (1)
Join Date: Oct 2004
Location: Kent State, Kent Ohio
Posts: 7,367
yea somethings defenatly not right if your giving it full gas and its not downshifting, like bob said make sure your in O/D
 
  #7  
Old 03-10-2006
Member
Thread Starter
Join Date: Feb 2006
Location: Hawaii
Posts: 12
even if its in regualr D wit o/d off it still dont shift. But on occasion, it shifts and we go flying. Maybe the fuel filter, but a CEL for an bad EGR flow wont affect it would it?(thats what i got...)
 
  #8  
Old 03-10-2006
V8 Level II's Avatar
RF Veteran
iTrader: (4)
Join Date: Nov 2004
Location: Michigan
Posts: 7,910
Originally Posted by Ranger808
a CEL for an bad EGR flow wont affect it would it?(thats what i got...)
The EGR has no effect at WOT because it is turned off at WOT. Are you sure that you haven't picked up an additional code since you had it read for the EGR code? You can have multiple codes but you only get one CEL.

Any problems at all with the speedometer? 98~00 Rangers are notorious for bad ABS/VSS sensors that make the speedometer and transmission act up.
 
  #9  
Old 03-10-2006
Rand's Avatar
Member
Join Date: May 2004
Location: Barberton,Ohio
Posts: 1,189
Mine would do this occassionally like I wanted it to shift to 1st gear at 35mph and it stayed in 2nd... Try pumping the gas once and see if it shifts down.
ie. Let off the gas then back on wot(as fast as you can)

My chip fixed it though..

Rand
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bigredneck61088
Drivetrain Tech
3
08-03-2010 09:03 AM
chas9rr
Drivetrain Tech
0
08-04-2007 06:12 PM
BoeingMan
Drivetrain Tech
14
07-13-2005 09:03 PM
BoeingMan
4.0L OHV & SOHC V6 Tech
6
07-13-2005 06:43 AM
doc
Ranger-Forums Office
4
05-12-2005 06:48 PM


Thread Tools
Search this Thread
Quick Reply: Automatic's Downshift


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.