Cruise Control stopped working - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-15-2010
Member
Thread Starter
 
Join Date: May 2005
Location: Tucson, AZ
Posts: 175
Cruise Control stopped working

I have recently been assigned to work for 6 months in a city about 100 miles away from where I live, so I will need to use my cruise again. So after a few months of not using it, I tried to turn it on the other day and nothing happened. I'm not sure what it could be. I press the on button, and nothing happens. Anyone have any ideas where I should start checking? I know the fuse is tied to the turn signals and those still work, so I have ruled out a fuse. Could the button/pod itself be bad? What else should I check? Thanks!
Reply With Quote
  #2  
Old 07-15-2010
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
Did you ever get a letter about the recall associated with the cruise control?

I doubt it is directly linked to this problem, but I got mine fixed for free at the dealership
Reply With Quote
  #3  
Old 07-20-2010
Member
 
Join Date: Jul 2010
Location: Glendale, AZ
Posts: 27
hmmm, I have the same problem, no cruise control.
I haven't checked the fuse yet, but I also have no windshield wipers either.
What is this about a recall? can someone elaborate?
Reply With Quote
  #4  
Old 07-20-2010
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
I got a letter like 2 years ago telling me there was a possibility that the cruise control would catch fire or something.

All I know I took it to the dealership and they replaced the cruise control for free, even though mine worked fine
Reply With Quote
  #5  
Old 07-21-2010
rstangboi's Avatar
Member
 
Join Date: Jan 2008
Location: Davis, Ca
Posts: 2,583
ya i gotta get on this too...my **** stopped working the other day...wonder if its my clockspring i broke though lol
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Heat blower stopped, then started, now stopped heat works nanookc General Technical & Electrical 4 02-17-2015 02:18 PM
2001 ranger cruise stopped working johnh General Technical & Electrical 5 08-22-2013 08:08 PM
Cruise stopped working robert99ranger General Technical & Electrical 13 05-07-2012 02:14 PM
Modding cruise control to a non cruise Ranger 2001fordranger General Technical & Electrical 1 07-29-2009 11:58 PM
cruise control stopped working after tranny fluid change. mps01r6 2.9L & 3.0L V6 Tech 11 03-18-2009 06:37 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:36 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.