Check engine light - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-12-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: Old Hickory, TN
Posts: 3
Check engine light

Hello all. My 94 Ranger 2.3 has the check engine light on and running a little rough during acceleration. Hooked my scanner to it but it says vehicle not responding?
I know it is connected correctly and when I hit scan the engine jumps and the light goes off for a second. Anyone seen this before?
If I could get a scan I could fix it and scanner works fine on other vehicles.
I bought it new in 94 and it is simply part of the family. Got to get it fixed. Any ideas (within reason) will be tried. Thanks
Reply With Quote
  #2  
Old 08-12-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Are you sure you are using the right scanner ?
94 was OBD I.
An OBD II scanner will not work.

Check this link for help; https://www.ranger-forums.com/f13/i-...e-codes-58160/
Reply With Quote
  #3  
Old 08-12-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: Old Hickory, TN
Posts: 3
Positive. I have used it before on this truck a couple years ago when I first got scanner just checking it out. It hooks up to two connectors under the hood.
I have a different connector for OBD ll but on this truck only OBD l will hook up. I know it is making a connection because truck will idle up for a sec and the check engine light goes out for a few sec,s when I hit scan but then it reads "Vehicle not responding".
I tried dis-connecting battery hoping something would reset but of course only radio reset and light came back on.
Thanks
Reply With Quote
  #4  
Old 08-12-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
I know on OBD II there is a fuse which powers the port for the diag tool , but I don't know if this is true for the older OBD I ports , maybe check/recheck the fuses.
Reply With Quote
  #5  
Old 08-13-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: Old Hickory, TN
Posts: 3
Just in from work and going to get started on it. I will check the fuses first and see.
Probably should have done that first, oh well hindsight and all that.
Thanks I will let you know
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Check Engine & Check Pants! Brian5792 4.0L OHV & SOHC V6 Tech 2 07-21-2014 04:24 PM
99 Ranger: engine wont turn over, has power, and no check engine light sprx26 General Technical & Electrical 1 03-19-2014 12:07 PM
o/d light, check engine light and rough idle wtf man 2.9L & 3.0L V6 Tech 8 02-23-2014 01:39 PM
problem with engine and check engine light warner.325 SOHC - 2.3L & 2.5L Lima Engines 5 12-09-2009 04:48 AM
spedometer out + ABS light + check engine light joey v General Technical & Electrical 13 06-17-2008 08:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:45 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.