Truck getting horrible gas mileage - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-24-2011
Member
Thread Starter
 
Join Date: Jan 2011
Location: Corydon, iowa
Posts: 2
Truck getting horrible gas mileage

99 Ford Ranger XLT, 4.0, automatic, 4x4.
Im having some issues with finding out what is wrong with my truck. it throws codes 0174 0173 saying bank 1 and 2 running lean. Checked intake gasket, maf sensor and air box and black tube. Nothing. Its getting about 9 mpg or 160 to 180 miles to 16.5 gallons of gas. Ive heard fuel pressure regulator? Vaccum lines behind motor? Cant find the problem and ist driving me nuts. Doesnt have rolling idle or anything idles great. Please Help!!
Reply With Quote
  #2  
Old 01-24-2011
malydeen's Avatar
Member
iTrader: (12)
 
Join Date: Jul 2007
Location: Minneapolis, MN
Posts: 632
Winter blend gas. They add in 10-15% ethanol and you get crap for milage. Its happening to all of us.
Reply With Quote
  #3  
Old 01-25-2011
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Quote:
Originally Posted by Dildoyle99 View Post
99 Ford Ranger XLT, 4.0, automatic, 4x4.
Im having some issues with finding out what is wrong with my truck. it throws codes 0174 0173 saying bank 1 and 2 running lean. Checked intake gasket, maf sensor and air box and black tube. Nothing. Its getting about 9 mpg or 160 to 180 miles to 16.5 gallons of gas. Ive heard fuel pressure regulator? Vaccum lines behind motor? Cant find the problem and ist driving me nuts. Doesnt have rolling idle or anything idles great. Please Help!!
Check your fuel pressure, have you ever changed the o2's? Also fuel injector cleaner once in a while will help.

Sadly 11mpg is about the norm in this cold weather. Last tank I did 14 but, I did not let the truck warm up at all before I drove. If I let it warm up 5-10 I will be in the same 10-12 mpg range.
Reply With Quote
  #4  
Old 01-25-2011
Member
Thread Starter
 
Join Date: Jan 2011
Location: Corydon, iowa
Posts: 2
never checked 02s but the computer says theyre reading right when its running. Before winter though it was still doin bad.
Reply With Quote
  #5  
Old 01-25-2011
fourliter dan's Avatar
Member
 
Join Date: Dec 2007
Location: Lebanon, OR
Posts: 2,229
im assuming you have a SOHC. these codes come up. generally the consensus is this....

Name:  IMG00072-20100228-1013.jpg
Views: 17
Size:  114.4 KB

i had the same issues and changed everything!!!(except the 02's) this is what it turned out to be. the rubber elbow had cracked on the bottom of the hose and was causing unmetered air into the engine causing it to run rich and still not compensate for the extra air in causing both codes.
Reply With Quote
  #6  
Old 01-25-2011
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
99 has the ohv.
Reply With Quote
  #7  
Old 01-25-2011
STUPIDHEAD11's Avatar
Member
 
Join Date: Oct 2010
Location: Melbourne, Florida
Posts: 219
hahaha this are my thoughts exactly. I went through a tank of gas in 2 days of normal driving. true story. truck still does this. threw a 20 in her on the way home again since sunday
Reply With Quote
  #8  
Old 01-25-2011
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
Sounds like you have an 02 sensor issue. 10-15% is the normal ethanol blend all year, cold temps require more fuel, although not as much fuel as you're using. I'd check 02's and go from there
Reply With Quote
  #9  
Old 01-26-2011
chainfire's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2007
Location: Mission B.C.
Posts: 3,126
It might throw the 02 sensor code, but also check your intake plenums. My OHV threw the 02 code, then once I replaced them, it came back on. Turns out it was the plenums that had hardened up and started to leak. Just a heads up.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Engine rebuild and now getting horrible gas mileage Bpat1017 General Ford Ranger Discussion 5 12-28-2012 11:34 PM
Horrible gas mileage :/ ?!?!!?!? TonyIce05 4.0L OHV & SOHC V6 Tech 14 12-22-2011 03:58 PM
Help my horrible gas mileage please!!!! geikoman170 General Ford Ranger Discussion 8 03-16-2011 04:44 PM
2.3L getting horrible gas mileage. 5speedin2.3 2.3L & 2.5L I4 Tech 18 09-11-2007 10:50 PM
Horrible gas mileage, suggestions? Southern4L General Ford Ranger Discussion 21 12-21-2006 04:19 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:01 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.