90 2.3 Ranger runs horrible - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-31-2016
Member
Thread Starter
 
Join Date: Dec 2016
Location: boise
Posts: 3
90 2.3 Ranger runs horrible

Hello everyone, so the other day i bought a 90 ford ranger off my buddy for dirt cheap. When he got the thing it was running decent, we changed the oil pressure sending unit and put the engine all back together and it started running bad. He said he plugged something in and it started running better but im not sure what he plugged in. The truck ran good all the way up till when i bought it. I went to his apartment complex and warmed up the truck, then proceeded to drive it back to my house. It was running great and all of the sudden the rpm started to rapidly drop and the trucks mph dropped as well. I was petal to the medal in first gear trying to get this thin to a parking lot going 10 miles an hour. The thing went from good to bad in a literal blink of an eye. I had my dad tow me back to my house and i did some research and came to the conclusion it was my cat. I did a vacuum test on the engine and wasn't getting a solid reading at idle, nor at a constant 2000 rpm. I unbolted the exhaust system and did the same thing, Rpm at idle wasnt stable but it was at 2000 rpm. I havent ruled it out yet but i dont think it is the cat, it looks like its been replaced. Next i chase the fuel pressure but im sitting on a solid 35 psi. The vacuum lines are all on and my truck isnt kicking any codes. The only thing left that i think it could be are the plugs or the fuel filter. I only checked one easily accessable plug and it looked fine but you never know. Any suggestions? Thanks for helping!!
Reply With Quote
  #2  
Old 12-31-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 6,746
Welcome to the forum

1990 Ranger will have the 2.3l SOHC Lima engine, not to be confused with the 2.3l DOHC Duratec engines Rangers started getting in mid-2001.

So if you google: "Ranger 2.3l" you will get conflicting information because there were two different 2.3l engines

OK, 2.3l Lima
Has 2 spark plugs per cylinder, BOTH spark plugs fire(spark) at every TDC, compression and exhaust stroke.
They do not alternate.
So you need two bad spark plugs in one cylinder for it to misfire from a spark issue.

But you can mis-wire spark plugs on Coil Packs, so double check that

Clogged exhaust will certainly cause a problem, but that problem gets worse as RPMs go up, doesn't get better.

Vacuum leak causes engine to run worse at lower RPMs, then it can smooth out at higher RPMs because small amount of air leaking in doesn't cause as much of a problem as engine air volume increases, i.e. a drop of poison in a swimming pool or in a shot glass.

You will need to do a compression test to take a few other things off the table.

The fact it "was running good" then suddenly wasn't could be bad gas, when was last time you got gas?
Reply With Quote
  #3  
Old 01-01-2017
Member
Thread Starter
 
Join Date: Dec 2016
Location: boise
Posts: 3
Ok, today i will check the compression and the coil packs. He had filled the truck up about two days before i got it and the thing gets killer gas milage so id imagine it is fine. I can run the thing for quite a while. Might jut change the fuel filter just to be on the safe side.
Reply With Quote
  #4  
Old 01-01-2017
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,093
throttle position sensor
Reply With Quote
  #5  
Old 01-05-2017
Member
Thread Starter
 
Join Date: Dec 2016
Location: boise
Posts: 3
Quote:
Originally Posted by cheese_man View Post
throttle position sensor
Cheese man you are a genius. Thank you!!
Reply With Quote
  #6  
Old 01-06-2017
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,093
you are welcome

oh replace the fuel filter as soon as possible , if you do not know if it has ever been replaced
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
horrible starting, revs up after starting. smokindmax SOHC - 2.3L & 2.5L Lima Engines 5 09-01-2009 10:33 AM
horrible timing....pun intended bruiser 2.3L & 2.5L I4 Tech 1 11-01-2007 08:41 PM
2.3L getting horrible gas mileage. 5speedin2.3 2.3L & 2.5L I4 Tech 18 09-11-2007 09:50 PM
Horrible gas mileage, suggestions? Southern4L General Ford Ranger Discussion 21 12-21-2006 03:19 PM
Horrible (9 MPG) mileage on 06 Ranger - can dealership fix? TommyC 4.0L OHV & SOHC V6 Tech 14 08-06-2006 11:44 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:50 AM.