Engine not starting when hot - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-06-2016
Member
Thread Starter
 
Join Date: Feb 2016
Location: Bridgetown
Posts: 6
Engine not starting when hot

I have a 2006 ford ranger 2.5l sohc diesel .
when this engine is cold this vehicle starts fine, but after reaching working temperature and is switched off it would not restart untill 45-60 before this engine would start again,after it has cooled it would start just fine again.can anyone tell me what is happening here or how to solve this problem.


nb)when hot engine just swings over
Reply With Quote
  #2  
Old 06-06-2016
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,615
You have an International Ranger, which is much different than the North American Ranger.

I know a bit about diesels but it is just general knowledge.

Has any work been done in the last year or so on the fuel system, especially the injectors?

If so then most likely issue will be a leak, bad seal, causing low fuel pressure no start after engine is warmed up

It could also be a bad IPR valve, same problem low pressure so no start until engine cools down.
Reply With Quote
  #3  
Old 06-07-2016
Member
 
Join Date: Mar 2014
Location: canton
Posts: 23
I know this much: It is NOT the sparkplugs, distributor, or ignition coil.

Possibly an injection pump that loses its seal and thus ability to develop pressure when it reaches a certain temperature. Kinda doubt all injectors would quit at the same time?
tom
Reply With Quote
  #4  
Old 06-08-2016
Member
Thread Starter
 
Join Date: Feb 2016
Location: Bridgetown
Posts: 6
Quote:
Originally Posted by RonD View Post
You have an International Ranger, which is much different than the North American Ranger.

I know a bit about diesels but it is just general knowledge.

Has any work been done in the last year or so on the fuel system, especially the injectors?

If so then most likely issue will be a leak, bad seal, causing low fuel pressure no start after engine is warmed up

It could also be a bad IPR valve, same problem low pressure so no start until engine cools down.
I recently had the injectors servive and had new toips put on an d recalibrated ,but thats was because of the same problem that i did that but thanks i'll have the pump checke
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Engine start problems when engine is hot mr.faby General Ford Ranger Discussion 1 06-06-2016 08:10 PM
stumped 2.3 engine not starting stevenxking90 SOHC - 2.3L & 2.5L Lima Engines 8 04-07-2011 09:52 PM
"HELP" 86 ford ranger,hard starting when hot philip General Ford Ranger Discussion 0 02-13-2011 07:18 AM
horrible starting, revs up after starting. smokindmax SOHC - 2.3L & 2.5L Lima Engines 5 09-01-2009 11:33 AM
4.0 Engine not starting Eibbor 4.0L OHV & SOHC V6 Tech 3 09-04-2007 11:59 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:04 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.