5.0L plans - Page 23 - Ranger-Forums - The Ultimate Ford Ranger Resource


8-Cylinder Tech If you are one of the few with a V8 engine in your Ranger, or if you dream of a Ranger with a V8 engine, this is the sub-forum for you.

Reply
 
LinkBack Thread Tools Search this Thread
  #551  
Old 06-21-2010
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
yeah if thats how the chain was setup the marks look right on the nuts, and with a keyway its pretty hard to get it wrong. Its got to be a strange mixture problem so maybe like roger that could hopefully be your problem.

I had a few powerloss issues,hesitating etc. it took me two fixes. bad connector on a injector and the other was a extra 02 sensor bung in my exhaust system that was letting air into the system and throwing off the next 02 in line. plugged it and it went away.
Reply With Quote
  #552  
Old 06-22-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
holy crap i never thought about my MAF.... if i tore this thing down for nothing imma freak lol. I can check that today hopefully if i have another one in the garage.

Now i did get my computer reflash by a Pro to accept the B cam.. could that have anything to do with it?

SO by everyones account, yes that pic was after final install, that is 100% correct?? cuz if i dont gotta pull the timing cover and regasket it that would be great. plus fast to check the MAF
Reply With Quote
  #553  
Old 06-22-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
"becasue it sounds like the same issues I went thru..Loading up and not running right..with ZERO codes "

Yea i put it in drive step on the gas and it goes but takes a while. but it will still grab without my foot on the gas. then while driving it somewhat bucks and pops n cracks. has the power of like a 3.0 not a 5.0 lol
Reply With Quote
  #554  
Old 06-22-2010
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Quote:
Originally Posted by mlw20lu View Post
Now i did get my computer reflash by a Pro to accept the B cam.. could that have anything to do with it?
The Explorer calibration, as it comes from the factory, has the reputation of not accepting cam mods. In fact. Ford Racing says that none of the Ford alphabet cams cams would be compatible. By extension, I would guess that you could say the same for other performance cams as well. I know that your PCM guy says he made mods to take care of that problem but we have no idea what those were.

Quote:
Originally Posted by mlw20lu View Post
pulled the plugs and the #5 cylinder was running super lean and the #7 was running super rich. all others were ok or little lean. those cylinders just stood out waayy more than others.
Actually, I'm having a problem accepting this as a global problem when you say that you're seeing lean or rich conditions on individual cylinders. Based on that, I'd say that things that affect all cylinders equally (like timing, MAF, camshaft selection, etc.) are low on the priority list.

For starters, I would concentrate on the one cylinder that is the most different from the other seven and see if there is an obvious problem that affects that cylinder in particular - stuff like injector, plug, wire, compression, firing order, valve leakage/damage or a vacuum leak/exhaust leak on that cylinder only.
Reply With Quote
  #555  
Old 06-22-2010
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Quote:
Originally Posted by mlw20lu View Post
"becasue it sounds like the same issues I went thru..Loading up and not running right..with ZERO codes "
Be careful not to get too hung up on this. Not every issue causes a trouble code and many problems take two or more drive cycles to light the CEL.
Reply With Quote
  #556  
Old 06-22-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
thanks Bob. appriciate the advice.

AS far as concetrating on that cylinder I have. We checked spark, injector, harness, compression, etc and that all is "A ok".

Im going to email the guy that flashed the comp and see what he says also. maybe he can shed a little more light on that subject.
Reply With Quote
  #557  
Old 06-22-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
SO hear is the latest.

Confirmed the timing mechanically is correct. Adjusted the CMP many diff ways. changed out MAF sensors and still running the same.

Curious.. i actually unplugged my CMP and started my truck. ran ehhh but not too far off from when plugged in.... Possibly simple as a bad CMP?

Also while turning the crank witha breaker bar I can hear at one point some air hissing out. Does not do it at every turn just when the crank gets to a certain spot.. could be normal or no?

Running out of options.
Reply With Quote
  #558  
Old 06-22-2010
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
i would send your pcm to nick if you cant figure it all out. pm him and see what he says about that. im not sure if he can tune with out the whole truck or not i talked to him about it a while ago i dont remember the details
Reply With Quote
  #559  
Old 06-23-2010
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
Quote:
Originally Posted by Downey View Post
i would send your pcm to nick if you cant figure it all out. pm him and see what he says about that. im not sure if he can tune with out the whole truck or not i talked to him about it a while ago i dont remember the details
not really going to solve much.

Mark if all the electrical is testing correct It has to be some sort of uncalculated air getting in/out somewhere. Like Bob said if you have individual problems its probably not a general engine issue that effects it as a whole like timing etc. If everything from the coil packs to the injectors are mint then its got to be a leak or something weird with the software for those cylinders you have a problem with. really check all the injector connectors cause the bad one i had looked fine and tested out fine but after just replacing because I couldnt figure out what else it could be that worked. It was causeing a strange loss of power only here and there though. Are you feeling this always no matter what? if its a static problem then it more than likely will be a pretty plain problem once you find it
Reply With Quote
  #560  
Old 06-24-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
yea man i dunno. Im gonna work on it some more today try and locate where the sound is coming from etc, try a different CMP, and if nothing goes right tonight im gonna have to take it in to someone. sucks man but i cant trial nad error anymore.
Reply With Quote
  #561  
Old 06-24-2010
stephen.g.fiddes's Avatar
Member
iTrader: (2)
 
Join Date: Mar 2010
Location: Tigard, OR/ Monmouth, OR
Posts: 847
Quote:
Originally Posted by mlw20lu View Post
yea man i dunno. Im gonna work on it some more today try and locate where the sound is coming from etc, try a different CMP, and if nothing goes right tonight im gonna have to take it in to someone. sucks man but i cant trial nad error anymore.
Watch, if you take it to someone, it'll be something stupid simple. Thats how it always works lol.
Reply With Quote
  #562  
Old 06-24-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
Id rather take it to someone and fix it with something stupid simple than have a breakdown trying to fix this thing and waste that much more time.
Reply With Quote
  #563  
Old 06-24-2010
stephen.g.fiddes's Avatar
Member
iTrader: (2)
 
Join Date: Mar 2010
Location: Tigard, OR/ Monmouth, OR
Posts: 847
yeah, I here you there.
Reply With Quote
  #564  
Old 06-24-2010
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
Yea stress is no good. Sure admitting defeat sucks,but having it done and being able to relax will feel great
Reply With Quote
  #565  
Old 06-24-2010
Scrambler82's Avatar
Old Guy Userů ltr
iTrader: (12)
 
Join Date: Jul 2009
Location: SoCal
Posts: 6,769
There is no trial and error method anymore, too many things can go wrong and be the same original problem.
You did more than I might do, this new electronics ia great thing IF running OK but a problem pop up and wam-bam you get it in the head.

good luck what ever you do.

Last edited by Scrambler82; 06-25-2010 at 03:16 PM. Reason: spl chk
Reply With Quote
  #566  
Old 06-25-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
Well i absolutely whole heartedly hate to admit it but i have officially thrown in the towel. I will be takin it to someone mid next week. Sucks but I have no where left to turn on my own. Ill keep yall posted
Reply With Quote
  #567  
Old 06-25-2010
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
Sorry to hear you couldn't get it figured out. At least it will get done.
Reply With Quote
  #568  
Old 06-25-2010
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
Atleast you didn't sell it.
Reply With Quote
  #569  
Old 06-25-2010
Topdog2007's Avatar
Level I Supporter
iTrader: (2)
 
Join Date: Aug 2009
Location: Blairsville, Ga
Posts: 466
I wanted to burn my truck when I was having issues like yours....I know its stressful as hell...especially with all the time, money and energy you have spent on it. But it will be worth it when everywhere you go people are either staring at you or asking 100 questions about your V8 Ranger!
Reply With Quote
  #570  
Old 06-25-2010
Scrambler82's Avatar
Old Guy Userů ltr
iTrader: (12)
 
Join Date: Jul 2009
Location: SoCal
Posts: 6,769
Mark, I am at the beginning of my 5.0L Swap (gathering parts) and do not know if anyone in my area will back me up so it is good you have a shop locally.
Best choice in the long run, once you are in the driver’s seat tooling down the road with the 5.0L purring away you will not remember what went wrong just the feeling of power.

Good Luck,
Reply With Quote
  #571  
Old 06-25-2010
Southern Dreamz's Avatar
Member
 
Join Date: Jun 2008
Location: Jupiter, Florida
Posts: 152
Cant wait to see it running around town !!
Reply With Quote
  #572  
Old 06-25-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
thanks everyone!
Reply With Quote
  #573  
Old 06-29-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
truck goes in thursday evening! so hopefully friday afternoon or Saturday we will have it fixed, have to take it somewhere else, or at least know the problem. YAY.

ps. anyone wonna trade trucks? lol
Reply With Quote
  #574  
Old 06-29-2010
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
I'll trade you.
Reply With Quote
  #575  
Old 06-29-2010
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
hah dont say that, you'll fall in love with it again soon enough. I have to get my bedsides asap cause I miss driving mine alot and I just want to take it out on these nice days and hear some 5.0
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Plans for a sub box onthefly4wd Audio & Video Tech 15 04-09-2006 10:51 PM
What My Plans Are For The V8 Swap! EdGe_wannabe 8-Cylinder Tech 62 02-13-2006 07:00 PM
Change of plans solodos General Ford Ranger Discussion 37 07-14-2005 07:52 AM
Plans for toughening the 4x2 a bit n3elz New Ideas 60 03-26-2005 11:18 PM
New System Plans Skyjacker_44 Audio & Video Tech 4 09-15-2004 11:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.