5.0L plans - Page 24 - Ranger-Forums - The Ultimate Ford Ranger Resource


8-Cylinder Tech If you are one of the few with a V8 engine in your Ranger, or if you dream of a Ranger with a V8 engine, this is the sub-forum for you.

Reply
 
LinkBack Thread Tools Search this Thread
  #576  
Old 06-29-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
Quote:
Originally Posted by rangerboy101 View Post
I'll trade you.
dont tempt me. Ive wanted a white one forever and i just found the Title in a box upstairs in my new office lol
Reply With Quote
  #577  
Old 06-29-2010
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
Quote:
Originally Posted by mlw20lu View Post
dont tempt me. Ive wanted a white one forever and i just found the Title in a box upstairs in my new office lol
I think blue would suit you better
Reply With Quote
  #578  
Old 06-29-2010
Topdog2007's Avatar
Level I Supporter
iTrader: (2)
 
Join Date: Aug 2009
Location: Blairsville, Ga
Posts: 466
Quote:
Originally Posted by 01RangerEdge View Post
I think blue would suit you better
Exactly what I was thinking!
Reply With Quote
  #579  
Old 06-29-2010
Member
 
Join Date: Apr 2010
Location: Rapid City, SD
Posts: 78
I wonder if you have the same problem I did. After i swapped my 5.0 in, it was good for a thousand miles or so, then proceeded to eat the cam sensor. I replaced it using the alignment tool and it ran fine for a couple days. Then it started sputtering and backfiring and got progressively worse till i couldn't drive it. I replaced lots of parts and finially got so pissed off that i parked it for a month.
I looked around and ended up scoring a pretty good price on another motor with much lower miles (400 bucks for a engine-FEAD with 85k). Dropped it in, and its run fine ever since. Hope you get it figgured out cheaper than i did, lol.

I am currently buttoning the origonal 5.0 back up to drop in my 88 tbird. It was surprisingly clean inside. The only sign something was wrong is that 4 of the intake valves are white, and 4 are black and almost oily. Engine is otherwise the best looking 150k block ive ever seen. In a few days, i'll see how it likes running with a distributer instead.
Reply With Quote
  #580  
Old 06-29-2010
stephen.g.fiddes's Avatar
Member
iTrader: (2)
 
Join Date: Mar 2010
Location: Tigard, OR/ Monmouth, OR
Posts: 847
I'll trade you :P

Reply With Quote
  #581  
Old 06-30-2010
Scrambler82's Avatar
Old Guy Userů ltr
iTrader: (12)
 
Join Date: Jul 2009
Location: SoCal
Posts: 6,780
Quote:
Originally Posted by mlw20lu View Post
dont tempt me. Ive wanted a white one forever and i just found the Title in a box upstairs in my new office lol
DON’T… you will love the truck when it is done.
This is why I have delayed so long on the V-8 issue, I am not up to speed on the new electronics and would get half way through and fall flat on my face but you have this almost done man, just hang in there.
think about how it will feel when the V-8 roars and you are driving with all that power under foot.

As far as the color, I think Mel looks great in the yellow truck.
Reply With Quote
  #582  
Old 06-30-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
well see.. after its all said and done theres not too much left i can do to this truck.. might want another project lol.
Reply With Quote
  #583  
Old 06-30-2010
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
SAS it.
Reply With Quote
  #584  
Old 06-30-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
ehhh its 2wd then id have to install a transfer case, etc... rather just build a new one. plus i dont wheel or mud or anything like that so an SAS , while sick, just isnt practical for me.... of course neither is this damn 5.0L
Reply With Quote
  #585  
Old 06-30-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
Quote:
Originally Posted by a77cj7 View Post
I wonder if you have the same problem I did. After i swapped my 5.0 in, it was good for a thousand miles or so, then proceeded to eat the cam sensor. I replaced it using the alignment tool and it ran fine for a couple days. Then it started sputtering and backfiring and got progressively worse till i couldn't drive it. I replaced lots of parts and finially got so pissed off that i parked it for a month.
I looked around and ended up scoring a pretty good price on another motor with much lower miles (400 bucks for a engine-FEAD with 85k). Dropped it in, and its run fine ever since. Hope you get it figgured out cheaper than i did, lol.

I am currently buttoning the origonal 5.0 back up to drop in my 88 tbird. It was surprisingly clean inside. The only sign something was wrong is that 4 of the intake valves are white, and 4 are black and almost oily. Engine is otherwise the best looking 150k block ive ever seen. In a few days, i'll see how it likes running with a distributer instead.
Man dont say stuff like that my stress level is at a high and it is my daily driver. i dont have the funds, time, patience, or anything to start over again. When i took the engine apart originally myself , my bro in law (who knows 5.0's), and another couple guys that saw it said everything looked great as far as the heads, valves, block, pistons, the hole 9 yards, so well see here after thursday i guess
Reply With Quote
  #586  
Old 06-30-2010
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
Quote:
Originally Posted by mlw20lu View Post
ehhh its 2wd then id have to install a transfer case, etc... rather just build a new one. plus i dont wheel or mud or anything like that so an SAS , while sick, just isnt practical for me.... of course neither is this damn 5.0L
Totally forgot you were 2wd... LT
Reply With Quote
  #587  
Old 06-30-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
id love a sport trac..... lol
Reply With Quote
  #588  
Old 07-01-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
So question about the truck again,

I reused the o2's from my 3.0... Could that be the cause??

Taking it in today
Reply With Quote
  #589  
Old 07-01-2010
Topdog2007's Avatar
Level I Supporter
iTrader: (2)
 
Join Date: Aug 2009
Location: Blairsville, Ga
Posts: 466
If they plugged right up into the Expo harness then I would say No. And it should give a code if it was.
Reply With Quote
  #590  
Old 07-01-2010
Member
 
Join Date: Apr 2010
Location: Rapid City, SD
Posts: 78
Yep, i reused mine also.
Check one of the part store websites to see if the part numbers are the same. They were for my 4.0.
Chris
Reply With Quote
  #591  
Old 07-03-2010
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
my 3.0 o2's were not the same, I replaced mine with explorer ones and it ran better. they are slightly different, also they are different for before cat and after.
Reply With Quote
  #592  
Old 07-03-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
hmmmm ill look into it
Reply With Quote
  #593  
Old 07-05-2010
Topdog2007's Avatar
Level I Supporter
iTrader: (2)
 
Join Date: Aug 2009
Location: Blairsville, Ga
Posts: 466
Any updates on possible issues from the Garage?
Reply With Quote
  #594  
Old 07-06-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
nope. no news. well no news on truck.. talked to Tony (ECM guy) and if it turns out that it is an ECM fuel/timing/ etc issue, i can simply take it to a local shop, Blow By Racing. And him and they will take care of it. so that is great.
Reply With Quote
  #595  
Old 07-06-2010
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
how long till its done
Reply With Quote
  #596  
Old 07-07-2010
mlw20lu's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Aug 2008
Location: Loxahatchee, FL
Posts: 1,825
latest update. called guy today.. he told me exactly wat it thought. Running lean ona few cylinders also truck wants to rev high before engaging... Im guessing the TUNE on the ECM is all messed up. hes gonna do some more testing and digging and get back to me. ill keep u updated..

still taking trade or purchase offers lol
Reply With Quote
  #597  
Old 07-07-2010
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Go make your own thread, stop hacking others.
Reply With Quote
  #598  
Old 07-07-2010
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
yes refer back to your original thread
Reply With Quote
  #599  
Old 07-07-2010
knightranger's Avatar
Member
 
Join Date: Jul 2010
Location: Edmonton
Posts: 8
that's very true int3rc3ptor,. i'm not trying to be a smartass here, just think about this for second if you will, but in a sea of one particular model of vehicle, whether it be a ranger, or corvette, or mustang, or any model of car, wouldn't you want to have something that really stands out from all the others?? I've never been one to follow the norm, i'm 42 now and don't plan on changing anytime soon, kinda set in my ways.....lol i appreciate your reply. take it easy.
Reply With Quote
  #600  
Old 07-07-2010
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
its ok i know what you mean, thats what i've been trying to do also. We are just trying to save you from a bunch of headaches and lost sleep. I would think your ford buddy could help you a lot more than us.


trent clean up as you need, no biggies
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Plans for a sub box onthefly4wd Audio & Video Tech 15 04-09-2006 10:51 PM
What My Plans Are For The V8 Swap! EdGe_wannabe 8-Cylinder Tech 62 02-13-2006 07:00 PM
Change of plans solodos General Ford Ranger Discussion 37 07-14-2005 07:52 AM
Plans for toughening the 4x2 a bit n3elz New Ideas 60 03-26-2005 11:18 PM
New System Plans Skyjacker_44 Audio & Video Tech 4 09-15-2004 11:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:01 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.